Crew App Payments Screen is Malfunctioning
Incident Report for Supermove
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 13:39 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2024 - 13:09 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 10, 2024 - 12:20 PDT
Investigating
We are currently investigating an error on the Crew App when the Payment screen is reached, impacting a subset of Supermove Tablets. Please note, Payments can still be processed through the Office App in real time. We will provide updates to this issue as soon as we have them.
Posted Apr 10, 2024 - 12:14 PDT
This incident affected: Crew App.