Error on Crew App

Incident Report for Supermove

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 08:46 PST

Monitoring

We've identified an issue affecting select users after a recent Crew App update. A fix has been implemented, and we are actively monitoring the results. To ensure you're on the latest version, all impacted users should manually restart their tablets.
Posted Feb 06, 2025 - 08:31 PST
This incident affected: Crew App.