Processing Refunds for Specific Transactions

Incident Report for Supermove

Resolved

This incident has been resolved.
Posted Jul 01, 2024 - 12:10 PDT

Identified

We have identified an issue preventing refunds from being processed on specific transactions. A fix is being implemented and we anticipate having an update early next week. If a refund is needed in the meantime, please reach out to help@supermove.com for assistance.
Posted Jun 28, 2024 - 13:56 PDT
This incident affected: Office App.