Error when manually Marking Jobs as Complete from Project page
Incident Report for Supermove
Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 11:06 PST
Monitoring
A fix has been implemented and we are monitoring the results. We will continue to provide updates as we have them.
Posted Feb 07, 2024 - 10:24 PST
Investigating
We are currently investigating this issue.
Posted Feb 07, 2024 - 08:47 PST
This incident affected: Office App.