Error Loading Emails in Email Widget

Incident Report for Supermove

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 16:20 PDT

Identified

We are aware of an issue preventing emails from loading in the Email Widget and are actively working on a fix. In the meantime, you can access emails through the Client Profile Page under Contact Information. We will provide updates as soon as more information becomes available.
Posted Mar 17, 2025 - 15:51 PDT
This incident affected: Office App.