AWS Outage Impacting Supermove Services

Incident Report for Supermove

Resolved

Supermove services have remained stable and fully operational since 19:59 PDT on October 20, following the widespread Amazon Web Services (AWS) outage. Since the incident, our Engineering team has been closely monitoring all systems to confirm sustained recovery and normal performance. This AWS outage affected many major platforms, including Amazon, Apple TV, Venmo, and Lyft.

We are actively collaborating with third-party providers to review integration data and ensure all queued requests are processed successfully.

For customers using Lead Provider Integrations, our team is reprocessing any failed or delayed leads, and no action is required on your end. If leads were already retried manually, this may result in occasional duplicate projects, which can be safely canceled if needed.

For customers using AI Sales Copilot, calls were connected and completed throughout the incident. A few calls may not be visible on the calls list right now – we are working on restoring the call records so that you'll be able to see all calls that happened in your account.

We want to emphasize that system reliability and customer trust are top priorities for Supermove. Our teams will continue to evaluate ways to strengthen platform resilience against external service disruptions like this one.
Posted Oct 21, 2025 - 17:05 PDT

Update

Supermove apps and services are now stabilized and operating normally following the AWS disruptions from today. Our team is continuing to monitor all apps and integrations to make sure everything remains fully operational.

We will share another update once the investigation is complete tomorrow and we've confirmed the full impact and next steps for integrations and additional services.

Note: Customers using Lead Provider Integrations can manually retry affected requests by selecting the errored logs and choosing "Retry Requests" in the top-right corner. Our team is also working on a solution to automatically re-run these requests for all impacted accounts.
Posted Oct 20, 2025 - 19:59 PDT

Monitoring

Intermittent errors continue to affect certain Supermove services, though overall performance is steadily improving. Refreshing your Supermove page(s) may help resolve isolated errors. Our team is actively monitoring the situation and will provide another update within the next hour, or sooner if significant developments occur.
Posted Oct 20, 2025 - 19:07 PDT

Update

Intermittent errors are still impacting some Supermove services, though overall functionality continues to stabilize. We recommend manually refreshing your Supermove page(s), as it may resolve individual issues. Our team continues to monitor the situation actively, and we will provide another update within the next hour, or sooner if significant developments occur.
Posted Oct 20, 2025 - 17:01 PDT

Update

We continue to monitor Supermove services closely as functionality gradually stabilizes. Our team remains engaged and will provide another update within the next hour, or sooner if any significant developments occur.
Posted Oct 20, 2025 - 16:28 PDT

Update

We continue to experience intermittent errors across Supermove services; however, functionality is gradually being restored. Our team is closely monitoring the situation and will provide another update within the next hour, or sooner if there are any significant developments.
Posted Oct 20, 2025 - 15:04 PDT

Update

We are continuing to monitor the progress of AWS's recovery efforts and are seeing gradual improvement across Supermove services. Our team remains actively engaged and will provide another update within the next hour, or sooner if there are any significant changes.
Posted Oct 20, 2025 - 14:12 PDT

Update

Supermove web apps (Office, Crew, and Copilot) are experiencing errors due to the AWS outage. We will post more updates as the applications start to service all requests normally.
Posted Oct 20, 2025 - 13:10 PDT

Identified

This issue has been identified by the AWS Team, and a fix is being implemented. We will continue to provide updates to this issue as we have them.
Posted Oct 20, 2025 - 12:09 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 10:35 PDT

Update

We are continuing to investigate this issue. Please note that the Supermove web and mobile apps continue to operate as normal.
Posted Oct 20, 2025 - 10:22 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 10:18 PDT

Investigating

We are currently experiencing a service disruption due to a widespread AWS (Amazon Web Services) outage. This is affecting multiple areas of the Supermove platform, including payment processing, lead submissions, the Support chat widget, and more. Please note that the Supermove web and mobile apps continue to operate as normal.

Our team is actively monitoring updates from AWS and will restore full functionality as soon as the issue is resolved. We will continue to provide updates here as more information becomes available.
Posted Oct 20, 2025 - 10:14 PDT
This incident affected: Office App, Crew App, AI Copilot, API and Additional Services (AWS, Payment Integrations, Reports, Email Integration, Twilio (Phone & SMS), Support Ticketing & Help Center, Lead Integrations, Calendar Integration).